Suzuki Burgman USA Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I bought some side visors (wind deflectors) for my 2011 Burgman 400, installed them, and after a week or so the double stick tape has come undone on about a 2 inch section of the right visor. I contacted oneida suzuki (where I ordered them online) via their website on how to fix this but have not heard from them, and their phone number is just a recording.

I'm also concerned the it may blow off over time.

Any one have an ideas on how to fix this problem ?
 

·
Registered
Joined
·
585 Posts
Use a quality contact cement. That sticky foam tape that comes with most glue on accessories is ok but won't hold up to constant buffeting by the wind. Clean that off - all of it before using the contact cement. Place the deflector mount where you want it then use tape to keep the contact cement from bleeding over onto the surfaces where it isn't needed and would look unsightly.
 

·
Premium Member
Joined
·
279 Posts
Did you clean underneath really well before sticking them on? I used alcohol and then buffed it real good first, Mine have been on nice and tight for five or six years now.
 

·
Premium Member
Joined
·
3,008 Posts
David94 said:
I bought some side visors (wind deflectors) for my 2011 Burgman 400, installed them, and after a week or so the double stick tape has come undone on about a 2 inch section of the right visor. I contacted oneida suzuki (where I ordered them online) via their website on how to fix this but have not heard from them, and their phone number is just a recording.

I'm also concerned the it may blow off over time.

Any one have an ideas on how to fix this problem ?
I had a similar problem with side air deflectors, maybe 1 inch not 2, but they never came loose.
 

·
Registered
Joined
·
2,860 Posts
forget those Adhesive Strips over time there gonna come loose, The best stuff I used was RTV Silicone in Black, never had them come off!! Since.
that Adhesive tape looks Nasty between then any way. mines did not come with Black Adhesive tape, there factory Grey.

Elliott,
 

·
Registered
Joined
·
1,060 Posts
I got side deflectors too and they did get loose, what I did was to remove the the original tape and replaced with a new thicker 3M double sided tape, that was it, problem solved, rain and strong winds are no problem.

I'd recommend you to get a 3M double sided tape and replace the original one.
 
1 - 6 of 6 Posts
Top