Suzuki Burgman USA Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
435 Posts
Discussion Starter #1
After two and and a half days (hour here, hour there, two hours here,etc.) I have finally finished installing my Givi E52. I bought the mount last year and finally was able to buy the box last month. It was not very easy, no, it was hard. Not complicated, but frustrating. Things just didn't line-up, fit or were hard to figure out just what the little photos were showing.

I did remember many words and phrases I leaned in the Army!

Now all I have left to do is mount the connecting plug, the little 3-wire, plug and twist to lock.

To those who have installed the E52 on a 650, where did you put the plug?????? The instructions say to measure over from the middle of the box 6 - 8", but that puts it right at the mount. I was thinking about putting it near the handle on the right side but under.

Help, please. :confused:
 

·
Registered
Joined
·
2,834 Posts
3 wire plug ???

GIVI electric supply have only 2 part.

If E52 case have GIVI brake light it only 2 wire system. Givi mount base GIVI part 259 have hole already in mounting base to install small round connector with 2 shinny flat power lug, other (round one with 2 tiny springy male lug), go in bottom of E52 in prepare hole near back of case that make contact with lug on mount base.
 

·
Registered
Joined
·
435 Posts
Discussion Starter #3
Sorry, I installed the AdMore lighting LED set. It has the 3-wire plug.
 
1 - 3 of 3 Posts
Top