Suzuki Burgman USA Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
A bit of a long story.... I've been 650 Burgerless for 18 months whilst having my sons AN400 :-(

anyway, got my 'girl' back :) but not in great shape. The folding mirrors do not work, folding in or out, I've had the handlebar switch apart and found the two top orange / green cables have 12v power permenantly and one bottom green cable has 'switched' power, on pressing the switch the other bottom green cable is 'switched' live and the other off, I guess this is correct 'switching'. On pressing the switch I could here a clicking from the relay, after finding it I found one cable to be permanently live as far as I can tell the other wires are not.

Is there a fuse somewhere ? (which I can't imagine was blown as wires have supply.) Or is the relay likely to be at fault although it's 'clicking' ?

Thanks in advance,

Martin
 

·
Registered
Joined
·
1,536 Posts
The fuse for the electric mirrors is behind the console cover. You will have to remove the console cover (the large plastic piece that surrounds the ignition switch) It is held on with 4 fasteners on each side. Remove these and the mirror fuse is on the right and is marked "MIRROR" - I think it is 3A. This is all from memory but I think it is correct.
 

·
Premium Member
Joined
·
14,257 Posts
Have you tested the relay. The one hot wire you found that is always on is the wire that feeds current to the mirrors. When you press the mirror button that should make the other wires also show hot. One will become hot because it is getting current from the button and the ground side of that circuit will also hot. The other will become hot because the relay will trip and allow current to flow through from the always hot power wire.
 
1 - 4 of 4 Posts
Top