Suzuki Burgman USA Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
605 Posts
Discussion Starter #1
Hey guys,

I must be missing something here but after changing my oil, I tried reseting the oil change indicator and haven't been able to get it done. I hold down the two switches (whatever they are called) and then turn the ignition switch on, hold for two seconds if not longer. The light should flash on and off (light that indicates oil change). When I do this the clock starts flashing the hour digit...it wants me to change the clock time. Maybe I should turn the ignition on first then hold the switches or what......
 

·
Registered
Joined
·
51 Posts
Timothy Ma said:
Hey guys,

I must be missing something here but after changing my oil, I tried reseting the oil change indicator and haven't been able to get it done. I hold down the two switches (whatever they are called) and then turn the ignition switch on, hold for two seconds if not longer. The light should flash on and off (light that indicates oil change). When I do this the clock starts flashing the hour digit...it wants me to change the clock time. Maybe I should turn the ignition on first then hold the switches or what......
I think I only held down the switch on the right as I turned on the ignition.
 

·
Registered
Joined
·
13,278 Posts
Turn off the ignition switch. Press and hold the Adjust button (right hand button under the tach) and turn on the ignition. Wait 2 seconds until the indicator blinks and goes out.
 

·
Registered
Joined
·
605 Posts
Discussion Starter #4
OK thanks guys....I'll do this and this should reset my oil change light interval.
 
1 - 4 of 4 Posts
Top