Suzuki Burgman USA Forum banner

1 - 17 of 17 Posts

Registered
Joined
3 Posts
Discussion Starter · #1 ·
I've got an 08 650. I put it up in storage after only 750 miles. Now I am getting it out and want to run it.
Replaced spark plugs, fuel pump and battery.

It doesn't throw any codes, but will not start up. Any ideas?
 

Premium Member
Joined
3,928 Posts
Is it turning over ?

Are the Plugs firing ?

Kill Switch in Run Position ?

Side Stand Swung Up ?
 

Premium Member
Joined
3,928 Posts

Premium Member
Joined
3,928 Posts
Tie the left brake lever with a shoe string so you have a free hand.
 

Super Moderator
Joined
12,511 Posts
Double check to make sure the side stand switch isn't sticking. This is not uncommon.
  • Try with both brake levers (one at a time should do it) in case one got bumped or is being annoying.
  • Check to make sure your coils are seated properly. Also not uncommon after changing plugs.
  • Use a jump box or (non running) vehicle jump for extra zip & crank it a LOT. If I ignore my K7 for even a couple weeks (I have a couple bikes) it's fussy like that, & takes some spin at WOT to get going. (don't let your starter overheat..)
As Dave notes at the bottom of this one.
"...hooked up a jump starter to and I held the throttle wide and cranked it for 10 seconds. It sputtered. Waited 15 seconds and did it a second time and it fired up and ran. Took it around the block at it ran fine... "
 

Premium Member
Joined
13,042 Posts
on the 15 if the kill switch is on, it won't turn over, if the sidestand is down, it won't turn over dunno about the 08
with no codes, and having monkeyed with the fuel pump I'm thinkin ,,,, can you hear the pump priming when you turn it on ? and replaced battery, ok but still,, try jump startin it cause its a cheap and easy thing to do and if it works you can buy refresin beverages to celebrate . also the put it up on center stand and twist the throttle thing is a good idea, then ,,, refreshin beverages. Be sure to let ius know the fix or all 53000 burgman usa members will come there and walk our dawg in your flower bed
 

Registered
Joined
1,650 Posts
Well, I'm curious. Is 750 the total miles on the odo? What year did you put it in storage?
 

Premium Member
Joined
3,928 Posts
Well, I'm curious. Is 750 the total miles on the odo? What year did you put it in storage?
He need鈥檚 to name his bike "Rumpelstiltskin"馃槂
 
  • Like
Reactions: mikeyMarine

Registered
Joined
256 Posts
In these situations it's always the muffler bearing. Hard to find for a Burgman 650, but my secret sources say that you can take one from a 1956 Vespa 150 and modify it to fit. You may need a ball peen hammer.
 

Registered
Joined
1,236 Posts
How long was if mothballed? The old gas will be like varnish. Did you fill the tank to the brim prior to parking it up? Do you have spark? Fresh fuel? As usual lack of information generates a million questions
 

Administrator
Joined
20,594 Posts
If mothballed since 2008-09 then did rodents get to chewing the wiring?
 

Administrator
Joined
20,594 Posts
I've got an 08 650. I put it up in storage after only 750 miles. Now I am getting it out and want to run it.

Replaced spark plugs, fuel pump and battery.

It doesn't throw any codes, but will not start up. Any ideas?
(Charles L answers)
Is it turning over ? Yes
Are the Plugs firing ? Believe So
Kill Switch in Run Position ? Yes
Side Stand Swung Up ? Yes
Replaced fuel pump. I assume he drained the tank when he did. The 650 has a Polyethylene tank so no rust inside like the 400's.

I still think put it on the center stand and pull full throttle and hold it while cranking it over.
 
1 - 17 of 17 Posts
Top