Suzuki Burgman USA Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Help! 650 Burgman when I apply either brake, I get a click sound.
the starter switch is dead...seems like a spring broke.
Engine starts when I turn on ignition and pull left brake handle
stater switch does nothing
any thoughts??
thanks, John
 

·
Premium Member
Joined
·
14,235 Posts
If I understand your post correctly, the starter switch is stuck in the on position. I gather this from you statement that you can turn on the ignition switch and pull the left brake lever and it activates the starter. I also gather that you think both brake light switches are functioning because you can hear a click when you pull them. This would imply that if you turned on the ignition switch and pulled the right front brake lever it would also activate the starter.

I would say you probably should repair this before you ride the bike. Otherwise you will be activating the starter every time you pull the brake levers. You can try taking the starter switch off and taking it apart. You may find the problem and be able to fix it. Several folks have successfully done repairs on this switch and report it is fairly simple in design. If you can't fix it you will probably have to buy a new switch.
 

·
Administrator
Joined
·
18,388 Posts
John, I bet your headlights are out too. Try a shot of WD-40 in the button area. Works on some.

The 05 and up 650s have a headlight disconnect while starting.
 
1 - 5 of 5 Posts
Top