Suzuki Burgman USA Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Ok so was tuning the carb when it made a weird noise and just cut off, would not start and with a slight hiss. Took the head off to find out 1 of my exhaust valve is slightly bent (difficult to see physically) but when i try to turn it by grabbing the steam it is not perfectly round and will not seal or sit properly.

My burgman is actually a skywave 400 an400x 1999mdl and my question is, does it use the same engine as with the FI models you guys have in the US? I am from The Philippines, i can only source it through ebay but the ad says its for the k2 2003-2006.

Thanks
 

·
Premium Member
Joined
·
14,227 Posts
I can't answer that for you as we in the USA never had the earlier than 2003 400 so I don't have any cross reference information to look at.

Maybe one of the members from Europe where they do have the earlier model bikes will know the answer.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
is it more than likely or less likely to be compatible? the belt, rollers and everything CVT is the same even the front end of the k series is the same as with mine its just the tail end which is different.

The head is a rocker type is it the same as the K-series? or is it shim? if its a rocker then i'll take my chances and get the part off ebay.
 

·
Premium Member
Joined
·
14,227 Posts
The head on the 2003-2006 is not a shim type. It has screw type adjusters.

If it is more or less likely to work I still can't tell you as I don't know if things like the water cooling passages and valve to piston clearance are the same.
 
1 - 4 of 4 Posts
Top