Suzuki Burgman USA Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2,862 Posts
Sounds like it's your Magic Blinker ,Mitch , China made Japan and China don't Mix ,there going to be problems had this issue Once, But it turned out to be the Blinker Unit it self, which Autozone is Made in Italy, Had to solder one end, Seem to have fixed the Problem.

Elliott,
 

·
Registered
Joined
·
2,862 Posts
One thing about the Stock Blinker is it is not a SPDT relay It's more a Circuit that just Was not a Good Blinker and Kept the Lights on to long on Repeating ,Did not make any Noise ,was one of the reasons to Replace it with a Clicker So you could Here it When Turned On when Blinking , LEDS did not work with It Because of Hyper flash, Some store One's are all ready equipped with Hyper flash-Stop Circuits. from the look of the Stock it's more Brighter then the Leds, The Leds on those are not as Bright One reason Why i chose to Make My Own Turn Signal LEDS because the One's on the Market are Still Not as Bright as the Stock, I still have my Silver Star Bulbs installed untill, i can find a Led that's Bright , The Only one is Vleds the V3 Triton 430 Lm on Amber But $140 is to Steep I can Build them for just $30 Bucks Using 600 to 900 Lumens ,I converted a Silver Star By Cutting Out the Filaments, inserted a 900 Lumen, But Accidentally cooked it. Not an Heat Problem But Voltage i forgot to connect the driver. My Goof

here's One of Mitch Videos
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top