Suzuki Burgman USA Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
709 Posts
Discussion Starter #1
My seat won't stay up and it slowly creaps down as i'm removing luggage. Needs new shock stay or is it set up like that from factory?
 

·
Premium Member
Joined
·
8,130 Posts
does it do it if you don't take anything out? raise back up if you put something in ? just kidding, it's common on the 400 do a search on seat struts and you will get your ansewrwererrewwerrr
 

·
Registered
Joined
·
143 Posts
Just like your car those "gas springs" loose it with time I sell a mechanical devise that replaces the stock strut If interested let me know Mark
 

·
Premium Member
Joined
·
3,008 Posts
I removed mine and use an aluminum pipe to hole the seat up. The pipe also serves as an extension to my short handled racket in my tool kit.
 

·
Registered
Joined
·
493 Posts
0.37$ mini spring clamp from Hone depot fixed my problem.

 

·
Registered
Joined
·
3,933 Posts
I have both handy in my trunk, a prop and a clamp, both work equally as well.
The prop can also double as a throw toy for my dog where as the clamp can't. :D
 

·
Registered
Joined
·
368 Posts
Chappy,

I was having the same problem with the seat lift on my Burg 400. I saw a thread on this forum about how to order & install a new lift that works much better than the OEM unit.

Unfortunately, with this redesigned site, I cannot find that thread. But I purchased my new lift from Lift Support Depot.com and installed it with the help of a friend. The total cost to me (including shipping & tax) was $25.79, and it was well worth it. No more need for dowels or clamps and the seat actually goes up by itself now.

The Code# was 10596E32 and the other number is 4142E32/10596E32 so that you order the lift with the correct 8mm eyelet fittings on the ends of the new hydraulic lift.

The lower nut can be tricky to remove & re-install so be extra careful with it. I suggest that you call them and make sure they know what it's for because they've now had several orders from our forum members.

I think the original post was by Jeff MDR on Jan14, 2012. Good luck!
 

·
Registered
Joined
·
1,664 Posts
Problem solved: I just place my helmet at the front of the seat after I raise it................!!! So simple, too!!
 

·
Premium Member
Joined
·
11,296 Posts
Chappy,

I was having the same problem with the seat lift on my Burg 400. I saw a thread on this forum about how to order & install a new lift that works much better than the OEM unit.

Unfortunately, with this redesigned site, I cannot find that thread. Snipped ..
Actually it is very much easier to search on this forum compared to the old. The reason for that - if you look at the top right hand side, there is an embedded google search facility which is much more powerful than what we had before.

I am struggling with the new software in the sense that it is unfamiliar to me - give it a year and we will all be used to it.
 

·
Registered
Joined
·
368 Posts
Norm,

Thank you for your comment. You are absolutely right - I had not tried to search for the thread via the new search feature. I incorrectly assumed that it would be like the old method which often caused me difficulty in finding the info I was seeking.
 
1 - 11 of 11 Posts
Top