Suzuki Burgman USA Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter #1
Followed Redbeards instruction to the letter and when test running the rig the control doesn't work. I used the modified switch instructions and it tested good on the bench. I ran the grey wire to the white wire on the speed sensor connector near the main fuses. When I have the motor running and push the (On) button I get the led (on) light to turn on and stay on, the engaged led also comes on momentarily and then turns off. But, when I get up to speed and push the s/c button nothing happens:confused: Any ideas to the guys who have been thru this?
 

·
Registered
Joined
·
753 Posts
Oh man. What happened I wonder?

I and a friend installed that Rostra on my 2007 Executive just a few weeks ago. Other than a slight clearance issue it all went on without a hitch. And I am happy to say that so far it has worked without a hiccup.

I wish that we were closer to each other so that we could compare why yours is having an issue. Even though I got confused a time or two (or three or four) during the install it did all work fine when I followed the instructions to the letter. Great instructions to be sure.

I do wish that I could be more help to you and tell you exactly why it is not working and what to do to fix it. The best that I can offer is to suggest that you retrace your steps and see if you wired up something wrong. I love my Burgman and having a genuine cruise control instead of throttle lock makes me love it that much more.

Please keep us posted what it was that was causing you grief and what you had to do to fix it. Might be helpful to others in the future.
 

·
Registered
Joined
·
704 Posts
I don't remember why Redbeard also shows a modified switch. Not being an electrical genius I mounted mine as it came strait out of the box and it works just as supposed to. I suspect that is where the problem is.

You have two hots, one not switched and the other switched, a ground and a speed sensor wire. Strait forward and simple. So simple even a cave man (me) can do it. The hardest is the actuator cable to throttle. Connect the control switch and done! Does the red light flash when turning the wheel in the test procedure? (Going by memory from over two years ago)
 

·
Registered
Joined
·
154 Posts
Discussion Starter #4
:confused: Problem solved! I have a power distribution box under the seat, I had not put a fuse in the circut for the cruise cause I didn't want power while installing and painting the bike. Forgot in all my excitement after putting the bike together to put a fuse in it. Power to the switch comes from the ignition and it lit up without power to the main control unit so that was throwing me off. Cruise works like a charm:p
 

·
Registered
Joined
·
255 Posts
You are going to get sooooooo spoiled with that Rostra cruise control. I've had mine installed for awhile and I absolutely love it. It makes running down the road so much nicer. Thanks again to Redbeard for his excellent installation instructions.

Greg
 

·
Registered
Joined
·
753 Posts
Yea! Hooray! I am SO glad it was an easy fix. I could hardly imagine it being anything much because as long as the instructions were followed it is pretty hard to mess it up. And if something can be messed up I am the one to do it. ;)

Going out of town to meet a friend for lunch and of course I will be on the Burg. And of course, as soon as I get on the highway my cruise will be on.

Aint technology great?
 

·
Registered
Joined
·
1,671 Posts
Sunday was my first day with the Rostra on the bike. Well, you know the story... same speed cruising... still getting used to it, but way better than the other stuff.
 

·
Registered
Joined
·
704 Posts
:confused: Problem solved! I have a power distribution box under the seat, I had not put a fuse in the circut for the cruise cause I didn't want power while installing and painting the bike. Forgot in all my excitement after putting the bike together to put a fuse in it. Power to the switch comes from the ignition and it lit up without power to the main control unit so that was throwing me off. Cruise works like a charm:p
Super! Now get out there and ride! Your face won't break from grinning, I promise.
 

·
Registered
Joined
·
1,671 Posts
Sunday was my first day with the Rostra on the bike. Well, you know the story... same speed cruising... still getting used to it, but way better than the other stuff.
 
1 - 9 of 9 Posts
Top