Suzuki Burgman USA Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter #1
I put led turn indicator lights on the mirrors of my 08 executive back around January. Today, while I was out for a ride, when I used the right turn switch I noticed the mirror led's were not lit up and the green turn indicator bulb, on the dash, was blinking very fast. I looked at the front turn indicator bulb in the mirror and it was not lit up. My guess is that when I open the mirror casing, I hope, the wires that I connected came loose. So, before I do does anyone think it might be either the bulb or is there a turn indicator flasher. Thanks for all helpful thoughts. Have a great day.
 

·
Administrator
Joined
·
18,201 Posts
I'd say the right bulb burn out. The blinker system flashes faster on one side when a bulb burns out.

Flasher unit would effect both Left and Right the same.
 
  • Like
Reactions: maccecht

·
Registered
Joined
·
79 Posts
Discussion Starter #4
I'd say the right bulb burn out. The blinker system flashes faster on one side when a bulb burns out.

Flasher unit would effect both Left and Right the same.
Thanks Dave....the bulb looks good. I've never tested a bulb before....can you check it with a volt meter or amp meter? Also the Led's did not light up.....only the green dash light blinking fast.....will post after getting new bulb
 

·
Administrator
Joined
·
18,201 Posts
It could be a broken wire before the bulb and LED connection. I'd recheck the wiring you did.
 

·
Registered
Joined
·
79 Posts
Discussion Starter #6
Eureka.....unhooked the turn signal led's and reconnected the turn signal bulb. She blinks like a beautiful woman.
Will reconnect the led's later but with a much better connection. Thanks again Dave for your assistance...Have a great day and keep the rubber down.
 

·
Administrator
Joined
·
18,201 Posts
The LED may have failed.
 
1 - 8 of 8 Posts
Top