Suzuki Burgman USA Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Hello,
I am experiencing some issue with the starter button. Sometime it seems to be difficult to start the engine due to a bad contacts probably.
I tried cleaning the side stand switch and the handle lever switch but the issue is still there.
No problem with battery, it is fully charged and works well.
Note that if I completely push the button, nothing happen. If I don't completely push the button the engine starts.
I think that the contacts inside the button are damaged (I tried cleaning it with some CRC66) and then I would like to know how to reach that contacts. I opened the switch but it seems to be impossible to reach the contacts.
Do you know how to reach them and if it is possible to change it?
thanks you guys
Have a nice day.
ciao
 

·
Premium Member
Joined
·
14,257 Posts
It is possible to take the start buttom apart. Quite a few folks on here have posted of doing so. The usual problem they are trying to solve is to get the headlights working. This thread has pictures of one taken apart http://burgmanusa.com/forums/15-burgman-650/76057-headlights.html

It is also possible that the problem is with the starter relay or with the starter it's self.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
It is possible to take the start buttom apart. Quite a few folks on here have posted of doing so. The usual problem they are trying to solve is to get the headlights working. This thread has pictures of one taken apart http://burgmanusa.com/forums/15-burgman-650/76057-headlights.html

It is also possible that the problem is with the starter relay or with the starter it's self.
Thank you Buffalo, the post has been very interesting and usefull and pictures really explanatory.
I am quite sure that the problem is on the contacts of the button, scooter is allways under the sun, the rain and the dust in a street with a lot of traffic.
I will ask to someone in that thread how to reach the contact, I think I will have to disassemble the trottle cables also, but I don't know how to do it.
thank you so much.
ciao
fausto
:eek:ccasion5:
 

·
Registered
Joined
·
1,204 Posts
Make sure the problem is not with the brake light switches.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #5
Make sure the problem is not with the brake light switches.
Thank you Osbornk,
I've already checked these switches and I am sure they both work fine.
Just this morning, as Buffalo has described before, I have noticed that also headlights doesn't turn on. Once the engine is started, pushing again the starter button, they turn on.
So, I am pretty sure that I have to check my starter button.
Does someone know how to disassemble the handle switch?
Thanks to all.
ciao
 

·
Premium Member
Joined
·
4,516 Posts
Check YouTube videos for
micbergsma
he has videos for almost all service & maintanance
for Burgman scooters. They are mostly for a 400,
but things like the handlebar controls will be similiar.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #7
Check YouTube videos for
micbergsma
he has videos for almost all service & maintanance
for Burgman scooters. They are mostly for a 400,
but things like the handlebar controls will be similiar.
Duster, you're great!!
It is exactly what I was looking for...
Interesting and usefull videos.
In the next weekend I will give it a try.
thanks again.
ciao
 

·
Registered
Joined
·
573 Posts
1 - 8 of 8 Posts
Top