Suzuki Burgman USA Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Can some one tell me if you can tighten up the mirror on my 07 650. some one bumped it and now its kind of floppy. It looks like if I take the turn signal lens out I might be able to tighten it. Not sure need some help.
 

·
Premium Member
Joined
·
14,258 Posts
Is it the mirror it's self that is loose or the mirror housing. If you remove the lenses you can see the back of the mirror but there in not much you can do with it. To remove the lenses look under the mirror and you will see a black plug. Pry that plug out and you will find a screw under it. Remove the screw then put the screw driver up into the hole it came out of and push against the lenses housing and it will pop out of the mirror housing.

If the housing is loose you will need to remove the handle bar covers and the front panel (dash) to gain access to the bolts. There are three bolts that hold it on. Two you get to from the dash side and one from the front behind the rubber shield between the mirror and bike.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks Buffalo, ya its the Housing that came loose.Someone did something to it yesterday and now its floppy. I am going to take it apart like you said I am just wandering what gives it that tension. is there a spring in there that makes it tight ??
 

·
Premium Member
Joined
·
14,258 Posts
If it is in the hinge where the mirror folds you may be out of luck. Not much way to get to it that I can see. It is not really designed to be repairable. Best you can do is take it off the bike then see if you can determine what is broke and if you can cobble it back together. I don't think there is any kind of a spring in there.
 

·
Registered
Joined
·
1 Posts
For what it's worth , I have the same fault, turns out that a spring has either broken or the spindle that its fitted to ( that provides the tension when placing the unit in the required position, retracted etc) has simply worn away and the spring has nothing to work against , anyway couldn't figure a fix for it so as a temp remedy I've filled the spindle area with "tec 7" put it in a usable position and allowed it to set.... Ordered a second hand replacement from ebay in the mean time. (It's useable for now) hope that is of some help.
 
1 - 6 of 6 Posts
Top