Suzuki Burgman USA Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
347 Posts
Discussion Starter #1
I would like to know from those people who have replaced the PPGA with the Polish gear, how has that been working for you after putting some serious miles on it? I read other posts guys buying 03,04 machines, being urged to replace this piece. I own a 03 and it sounds like a cummins diesel at stop and goes away under load. I don't have a problem with the dieseling noise, unless it is a problem. My understanding is this is normal for these particular models. Query; Does the Polish adapter fix, fix anything other than the dieseling noise? I watched the video on the installation and he was pounding on the thing for final seating, tapping I can understand,hammering is another. Are those gears supposed to fit that tight? I don't like to take things apart unless I have to.
I really like this bike, it is my first scooter. It is a blast to ride every time I get on it, except for the seat. It's awful.
 

·
Registered
Joined
·
735 Posts
I have almost 9000 miles on the Polish adapter, absolutely no problems whatsoever. I was worried about the hammering also, and I didn't do it. I used an impact driver which I had previously calibrated against a torque wrench to install the bolt, and used Loctite on it as the service manual specifies. I've done one long trip (2200 miles) and lots of 200-milers with it, plus lots of daily riding. Best money I've spent on the Lardy so far.

The original adapter seems quite weak, you can see in the photo I took that it has worn noticeably against the shaft splines. This was at about 18,000 miles on the bike.
 

·
Registered
Joined
·
347 Posts
Discussion Starter #3
Thank you much for the reply. This is the kind of info that I was looking for. I guess this is the kind of testimony I needed before I go buy the Polish adapter. By the way, awesome photo.
 

·
Registered
Joined
·
735 Posts
You're welcome. Forgot to add, the diesel noise went away and has never returned which tells me that nothing has worn or moved. Of course, with the engine that much quieter you will hear other things that might worry you. I hear a soft "thump" at idle that I didn't hear before, so did someone else on the forum. It seems to be at half engine speed or CVT input speed but it's never changed volume or characteristics so I don't worry about it.
 
1 - 4 of 4 Posts
Top