Suzuki Burgman USA Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
689 Posts
Discussion Starter #1
I have changes my oil twice now and I find it hard to achieved the proper oil level in the sight glass, on both occasions it took a few add and remove to reach the line in the glass. Since then I have checked the oil level each time I start and finish a ride and the level will not be the same as when I started, at times it is either on the line, below or above the mark and sometimes covers the sight glass completely. How important is it to have the oil at the proper level, will it cause harm to the engine if it goes a little below the line or about the line or all the way up to the top of the glass. This is driving me nuts.
 

·
Registered
Joined
·
2,385 Posts
Your not having a problem really, a little above or below the line is fine and almost expected, there are many things that will make the oil level appear to be off, the key word is appear. Just some of the things that make it almost impossible -- out side temp. in relation to how long since you stopped the engine -- condition of the oil filter - - If you were to leave the bike sit for a day, then run it but leave it sit another day before checking you mite get the same reading.
Perhaps someone else can explain it better.
But at least it was fun trying . :)
 

·
Registered
Joined
·
276 Posts
Its also very important to have the bike in the same position each time. Once, when washing the bike at a commercial washer, I thought I had lost all my oil when there was nothing in the sight glass. The concrete had a very slight slope to let water drain and I had parked the bike with the sight glass on the high side, exactly at right angles to the slope.
When I phoned my dealer about it, he said to check that the bike was level. I rechecked where I have it parked at home, on the level, and the oil level was correct.
Since then, I always check it before and after riding, parked at home.
Regards
 

·
Super Moderator
Joined
·
8,083 Posts
I had some weirdness last summer. My check oil light came on, and I needed about a 1/2 qt. I added as needed. The oil was changed about 500 miles later and the trans was 1/2 over over full. No answer as to why. It still seems to do that, but I'm not really concerned it seemes to run fine.
I do run a bit after oil changes in the tran, and final drive. It does seem to need oil after a 10 sec. run, normal.
You do need to wait a while after running it to get to the proper level for the engine, about 2-4 min. It can take a while for the oil to stabilize the level.
Now I only check it before I ride. The level dosen't really change during rides, a sudden change, is usually found before the next ride.
Hope it helps
 
1 - 4 of 4 Posts
Top