Suzuki Burgman USA Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I just recieved my banged up 07 burg and noticed that the fuses look good but still no turn signals or rear running light. Do they share a relay possibly that might have gottn banged up?

 

·
Registered
Joined
·
1,664 Posts
InfernoST said:
Is this suppose to be a joke?
I don't think that the OP intended to be a joke....!!! He seems to have asked an honest question about a possible wiring or fuse problem AND did post a pic of his damaged "07 400...
 

·
Registered
Joined
·
1,886 Posts
Sorry bout that it just looks very obvious where to start looking. 1st I hope who ever was riding that is OK!!!, 2nd I would pull off the front end tupperware and check to make sure all of the wiring loom connectors are still connected and no wiring in any of the harnesses got cut. Also did you check both fuse locations 1 on the left side of the dash and the high current fuses on the right side of the dash?
 

·
Registered
Joined
·
2,838 Posts
And, here's a link to the wiring diagram for the k7 as well. -> http://burgmanusa.com/bkb/K7+Wiring+Diagram

The ignition switch could be also at fault here as well, possible wire harness damage as InfernoST suggested.
 

·
Registered
Joined
·
1,177 Posts
For it to effect the turn and rear light I would check out the earth
as this would effect all 3.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7
Earth ground or what , I dont understand what you have said here? thanks for any help here.

Ralph M said:
For it to effect the turn and rear light I would check out the earth
as this would effect all 3.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #8
Thanks so much for the diagram thats extreamly helpful. Harness looks unscathed I was thinking the flasher relay maybe burned out when it got crashed as I noticed the flashers dont work either when you put them on at the handlebar switch. I bought the thing like this and just got it from a shipper, its going to be a naked bike when im done stripping all this tupperware :cheers:

TechArtGuy said:
And, here's a link to the wiring diagram for the k7 as well. -> http://burgmanusa.com/bkb/K7+Wiring+Diagram

The ignition switch could be also at fault here as well, possible wire harness damage as InfernoST suggested.
 

·
Registered
Joined
·
1,177 Posts
Earth or Ground same thing the wire in the diagram labeled B/W black and white
it Earth's or Grounds all the bulbs in the rear light.
 

·
Registered
Joined
·
1,177 Posts
You could try running a temp wire from the battery negative to the black and white wire
if the lights then work it's a earth ground/problem.
 

·
Premium Member
Joined
·
8,112 Posts
looks like hyou might have some trouble with the vent defog system too :lol:

good luck and have fun both doing it and riding it later
 

·
Registered
Joined
·
1,664 Posts
mikeyMarine said:
looks like hyou might have some trouble with the vent defog system too :lol:

good luck and have fun both doing it and riding it later

Mikey.......!!! ****! It looks like his defogging system is working just fine to me............ :lol: :lol:
 

·
Registered
Joined
·
19 Posts
Discussion Starter #14
Shes 28 lbs lighter so far
Any one know by looking at that ignition switch what wires can be eliminated as I want to put in a smaller simpler switch?? Thoughts
 

·
Premium Member
Joined
·
11,296 Posts
Well done looks like you have a good project here.
If I can offer you any advice it would be this - get that bike nekked- remove every piece of tupperware, the seat, the trunk box - the lot. It will pay dividends and save you time in the long run as you will be able to inspect and repair any wiring faults. It will also allow a good examination of the frame for damage.
 

·
Registered
Joined
·
709 Posts
Check bulbs, you'll be surprised how many times iv'e overlooked all bulbs blown, from somebody using a jump start, blah blah!
 
1 - 18 of 18 Posts
Top