Suzuki Burgman USA Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi Guys and gals.

I’m Mike from the UK, I have recently purchased ( a week before we went into lock down! A 2004/5 An650, it has approx 62K miles, with a lots of service history, I have just changed all of the brake discs, and refurbished the callipers. However a new fault has occurred today, after a fairly long ride.

In auto the bike pulls away, but the gears do not change, if I switch to manual, it will reluctantly change gear with numerous presses of the up button just to change one gear, if I switch back to Auto, the gears will decrease normally.

I think it could be one of the following:

1: the PPS sensor needs replacing $200 plus

2: the throttle sensor needs replacing. $170 plus

3: the left switch gear needs replacing. $30

I’m kind of hoping its 3, as this is cheap to do!

Any thoughts or theories would be gratefully received.
 

·
Administrator
Joined
·
18,199 Posts
First guess..... NONE of the above.

Check to see if the CENTER stand plunger is extending out with the center stand in the up posistion. That is the #1 cause of your type issue.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thanks Dave, however I should have qualified the fault, as it happens whilst the bike was in motion, slowing down for a roundabout, the pin is in the extended position on the switch, and it moves quite freely. I'll put this on another part of the forum.
 
1 - 3 of 3 Posts
Top