Suzuki Burgman USA Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
OK..I have a 2003 AN650 (non-EXC) with 15,000Km.

The other day, I noticed my LCD display going "in and out".

NOW...nothing...DEAD (except for the backlight)!! No speedo, fuel, F1, etc..!!

I have checked all the fuses and conections. Did not find anything out of the ordinary.

Starting to wonder if the ECU has gone bad? The local Suzuki shop (Italy) wants a CRAZY
amount of $$$ (Euro) just to look at it. Hopeing that someone can point me in the
right direction without dealing with them if at all possible.

Thanks!
 

·
Registered
Joined
·
3,975 Posts
If all the fuses are good the next step would be to check the power and grounds at the cluster connector with a test light.
 

·
Administrator
Joined
·
20,096 Posts
Kevin, see if the 2003 650's had a recall for the ignition switch in Italy and if it has been done on yours. In USA it was a free replacement. If it fails all sorts of issues pop up.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Thank you for the assist.

I did not know about a recall due to ignition switch. Any suggestions on how to determine if I fall under that recall??
 

·
Registered
Joined
·
3,975 Posts
KevinB said:
Thank you for the assist.

I did not know about a recall due to ignition switch. Any suggestions on how to determine if I fall under that recall??
Not sure about over there but here we just contact the dealer with the VIN and they run it in Suzuki's system to check for recalls and/or if its been done.
 

·
Administrator
Joined
·
20,096 Posts
I am sure Italy has a Vehicle Identification Number (VIN) and the Suzuki of Italy must track them that way. If they made a bad set of ignition switches for a year, Id say 99% that all markets world wide got bad ones.

Is there anything on the Burgman Italy site that none of us are allowed to join. Or http://www.burgman650experience.it/
 
1 - 6 of 6 Posts
Top