Suzuki Burgman USA Forum banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
409 Posts
Discussion Starter #1
I have noticed that my 2007 650 idles at 1,000 plus three bars at start up

When new it would idle at 1,000

Now I know that the 2007 650's was suppost to have an all electric throttle controller but there was a recall on this bike and they had the standard controller back on with an idle screw

Where is this throttle controller located?

Is it under the maintenance lid or do I have to dig deeper

Thanks in advance

Steve
 

·
Registered
Joined
·
3,933 Posts
Not familiar with the 650's idle adjustment but remember that they do have a high and low idle.
High idle is on at start-up to help warm up the engine and get the fluids flowing.
 

·
Premium Member
Joined
·
14,278 Posts
They did not put the manual idle adjustment back on it with the recall. They reprogramed the ecu. Your idle is still electronically controlled. There is not adjustment screw you can turn.

As the previous poster mentioned, it should idle faster when it is cold. The idle should drop back down when they bike gets fully warmed up. If it's not doing that then you may have a problem.
 

·
Premium Member
Joined
·
409 Posts
Discussion Starter #4
Thanks all for the reply's

Again when the 650 was new it would idle at 1,000 rpms in the mornings or then cold

At warm it would idle at 1,000 rpms

Now it idles at 1,000 rpms plus one bar warm

and 1,000 rpms plus three bars cold

I am at 18,000 miles and have not done the valve tappet inspection yet

Is there a connection?
 

·
Premium Member
Joined
·
738 Posts
whiteknuckler said:
Thanks all for the reply's

Again when the 650 was new it would idle at 1,000 rpms in the mornings or then cold

At warm it would idle at 1,000 rpms

Now it idles at 1,000 rpms plus one bar warm

and 1,000 rpms plus three bars cold

I am at 18,000 miles and have not done the valve tappet inspection yet

Is there a connection?
sounds to me like now its idling correctly
 

·
Premium Member
Joined
·
2,646 Posts
Yep, sounds like something was wrong when new, with only a 1K cold idle and now it sounds normal. Our 650 idles at 1750 cold start (3 tics past 1K) and quickly drops. Sometimes (momentarily) it will idle up to 2K when extremely cold.
 

·
Registered
Joined
·
218 Posts
whiteknuckler said:
Thanks all for the reply's

Again when the 650 was new it would idle at 1,000 rpms in the mornings or then cold

At warm it would idle at 1,000 rpms

Now it idles at 1,000 rpms plus one bar warm

and 1,000 rpms plus three bars cold

I am at 18,000 miles and have not done the valve tappet inspection yet

Is there a connection?
Perhaps your cable that actuates the throttle is too tight, there should be some play in the throttle cable when you twist it, about 1/8 to 3/16" play before the twist moves the cable, it's easy to adjust with the thumb wheel nuts on the end of the cables where it's attached to the handlebar.
Jim
 

·
Premium Member
Joined
·
409 Posts
Discussion Starter #8
rimjaine said:
whiteknuckler said:
Thanks all for the reply's

Again when the 650 was new it would idle at 1,000 rpms in the mornings or then cold

At warm it would idle at 1,000 rpms

Now it idles at 1,000 rpms plus one bar warm

and 1,000 rpms plus three bars cold

I am at 18,000 miles and have not done the valve tappet inspection yet

Is there a connection?
Perhaps your cable that actuates the throttle is too tight, there should be some play in the throttle cable when you twist it, about 1/8 to 3/16" play before the twist moves the cable, it's easy to adjust with the thumb wheel nuts on the end of the cables where it's attached to the handlebar.
Jim
I did toy with the throttle cable thumb wheels

Will adjust per above
 
1 - 8 of 8 Posts
Top