Suzuki Burgman USA Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I ride a 2009 400 Burgman and I am attempting to replace the right handlebar switch and throttle cables. Could someone tell me which plastic covering parts I need to remove in order to install both the switch and the throttle cables? Is this a tough install?
Thank you for any advice!!
RMKING
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
try, michbergsmas youtube videos, if it's 400 related, he's done it .
Thank you for replying. I do subscribe to him -He’s great! I just couldn’t find anything related to installing the throttle cables and what to remove to get there.
 

·
Premium Member
Joined
·
4,167 Posts
Thank you. That should come in handy. Still wondering if I can get to everything by removing handle bar covering and the front cover? Ty for any help
If the B400 and B650 are the same removing the handle bar cover is easy.

The SM I linked to should have good pics for you to see.
 

·
Registered
Joined
·
1,029 Posts
Throttle Cable Routing Diagram on pg 1D-2 (pg 146 of 475)
Throttle Cable Removal and Installation pg 1D-10 (pg 154 of 475)

Gonna be little more tupperware to remove than just the handlebar cover. ;)
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #9 ·
Throttle Cable Routing Diagram on pg 1D-2 (pg 146 of 475)
Throttle Cable Removal and Installation pg 1D-10 (pg 154 of 475)

Gonna be little more tupperware to remove than just the handlebar cover. ;)
Thank you for the page references. I see I'll learn how to remove and return the tupperware properly hopefully. thanks again.
 

·
Registered
Joined
·
1,029 Posts
Take your time. Don't get overly aggressive with the tupperware. Personally I won't work on it if temps are below about 60 deg.
Mitch has videos on removing nearly all the tupperware.
 

·
Registered
Joined
·
1,029 Posts
Reward yourself with a refreshing beberage...only AFTER riding. (y)

and thank you for posting the resolution/results
 

·
Registered
Joined
·
1,462 Posts
if I may ask...
you had to take the front off, correct? now, do these cables run down the right or left side of the bike frame? from the top view picture it shows left them running on the left side of the chassis but then it says to pass the cables on the side with the parking brake cable and seat unlock. there were simple reusable zip ties along the chassis to connect it to, yes?

did you take apart the middle hump out as well? I suppose probably bottom lower leg shield and the side panel as well? thank you.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #16 ·
Yes they run to the left and yes I had to take the front covering off. But what I did to avoid removing the middle covering, was I used the existing throttle cables (which were fine) and fed them into the new right handle part that replaced my broken starter button. It was a much easier fix and worked just fine.
 

·
Registered
Joined
·
1,462 Posts
thanks for explaning.

is there a sleeve the cables run in? basically you disconnected the connection inside around the engine, pulled it out from the throttle grip then im assuming used a little grease on the cable and slipped it into the sleeve down and reconnected on both ends? cheers
 
1 - 17 of 17 Posts
Top