Suzuki Burgman USA Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Changed rear drive oil at 600 miles now have 2,100 miles on it and have noticed "seepage/leaking" from possibly drain plug or some of the lower bolts --- anybody have this problem?
 

·
Registered
Joined
·
3,323 Posts
You don't specify what machine. I've not noticed any form of oil leakage or loss on my 650. Everything is dry.
 

·
Premium Member
Joined
·
11,296 Posts
HOGS said:
Changed rear drive oil at 600 miles now have 2,100 miles on it and have noticed "seepage/leaking" from possibly drain plug or some of the lower bolts --- anybody have this problem?
Sorry, but I think you have answered your own question.

There are 3 likely reasons for this oil seepage/leakage:

1. You overfilled it.
2. You spilt some and now this is finding its way out.
3. The filler/level plug is not in tight.

I am afraid your best option is to whip the covers up and have a check around, re-establish you have the correct level and secure the plugs iaw the spec.
 

·
Registered
Joined
·
3,323 Posts
allwalk said:
You don't specify what machine. I've not noticed any form of oil leakage or loss on my 650. Everything is dry.
DOH! stupid me ! I just noticed that you listed this under the 650 section so I will assume you have the 650.

and ditto what Norman said.
 

·
Registered
Joined
·
51 Posts
Mine howls like a banchee and slobbers oil all over the rear wheel. It's coming from the seal on the final drive gear. Goes in for service next week.
 
1 - 5 of 5 Posts
Top