Suzuki Burgman USA Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
604 Posts
Discussion Starter · #1 ·
Hello Guys,

I have about 4000 kms on my 400 and recently noticed when applying the brakes at noise coming from the front disc brake. It seems to happen at low speed (high speed application OK) so I thought maybe there was some dirt or dust on the pads or disc. Its like a rumble and not a squeal. The brake pads are fine but when I looked closely at the disc, there appears to be hairline type cracks in the disc. It is only in about 1/3 portion of the disc and I was wondering if anyone has experienced this as well. My dealership will be contacted and see if I can get this covered. Timothy
 

· Registered
Joined
·
604 Posts
Discussion Starter · #4 ·
OK, I went to my dealer and he said he had never seen such a thing. He also commented that the disc appeared to be glazed and hence hinted that I wasn't pounding on the brakes hard enough. I tend to agree since I tend to be gentle. So that last couple of days I have intentionly been hitting hard on the front brake.

I don't think I super cooled the front disc after a hard run. The cracks appear to be surface and very narrow. It's like the cracks in an egg shell but I still get this crunching sound especially when I apply the brakes at low speed. I have contacted the Suzuki service rep here in western Canada and will follow up with them. Hopefully the disc won't crack up during a ride. Not likely but never say never.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top