Suzuki Burgman USA Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
161 Posts
Discussion Starter #1
okay simple question on the front wheel where the speedo is the black speedo cover that goes over the bearing on that side do you have to have the dust cover on that side since the bearing is already coverd up just curious i know the left side requires it but does the speed odometer cable side
 

·
Registered
Joined
·
3,933 Posts
I can't remember for sure but it would be a good time to grease your speedo. :wink:
They will break on you if not regularly lubed.
 

·
Registered
Joined
·
161 Posts
Discussion Starter #3
well when i 1st got the bike it didn't have one on there so i put 1 on there but last night i took it apart and the one on the speedo side was just gone destroyed so thats why im wondering if it even calls for it i went on partzilla this am and i only see them calling for the 1
 

·
Premium Member
Joined
·
14,257 Posts
There is no separate seal on the sensor side but the bearing has a seal in it.

As Scootereno said, put some grease on the speedometer sensor rotor or you will be fixing it when it breaks. You can just pry the seal out to get access to the rotor. If you take care to not bend or damage it when you pry it out you can just reuse the seal. I pull my sensor off and regrease it every other oil change.
 

·
Registered
Joined
·
161 Posts
Discussion Starter #5
yeah iam going to do that again i did go to partzilla and cheapcycle parts and both show no cover over the bearing and only calls for 1 on the other side .got me some good red grease from penzoil when i put the wheel back on yes iam going to grease it good lol thanks guys
 
1 - 5 of 5 Posts
Top