Suzuki Burgman USA Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
562 Posts
Discussion Starter #1
Anyone else have trouble with theirs? It seems mine doesn't want to fit flush all the way in the front where your feet rest if they're stretched out in front of you. I can get one side to look normal and then the other side has a few mm gap and vice versa, it seems to fit everywhere else like it is supposed to. I'd like to see if this is normal or not before trying to replace it.
 

·
Registered
Joined
·
3,975 Posts
I had the one replaced under warranty on my '09 and after time it's worse than the original one. Personally I'd say leave it alone.
 

·
Registered
Joined
·
739 Posts
When I take mine off.. it takes me quite a few tries and a lot of back & forth adjustmewnts to get everything to fit back together again.. It should be easy, but it's not..
 

·
Registered
Joined
·
1,918 Posts
Noth said:
When I take mine off.. it takes me quite a few tries and a lot of back & forth adjustmewnts to get everything to fit back together again.. It should be easy, but it's not..
+1

It's a pain the butt.
 

·
Registered
Joined
·
153 Posts
The hump cover on my 2012 did not fit nearly as well as the one on my 04 the right side had a gap. The dealer replaced it but the new on does not fit any better than the first on so I guess there is no sense complaining about it any more. I have to take the dealers word that they replaced it don't know for sure whether they did or not.
 

·
Registered
Joined
·
1,068 Posts
Noth said:
When I take mine off.. it takes me quite a few tries and a lot of back & forth adjustments to get everything to fit back together again.. It should be easy, but it's not..
+2...still a pain in the butt after 9 years...but with patience...it will go :twisted:

Getting both front foot board slots engaged properly, followed by the two lower rear tabs, then the middle rear upper tab seems to be my sequence of choice...YRMV :roll:

Bill
 

·
Premium Member
Joined
·
11,296 Posts
I suspect you have managed to fit it with one of the locating tags outside of its intended slots.
 

·
Registered
Joined
·
153 Posts
I put mine back on have every tab and slot perfect after I get back from a ride the right side is all out of whack,the left side hangs in there pretty good. I had an 04 previous and once I put the cover on it stayed put until I removed it.
 

·
Registered
Joined
·
739 Posts
malahy1501 said:
Noth said:
When I take mine off.. it takes me quite a few tries and a lot of back & forth adjustments to get everything to fit back together again.. It should be easy, but it's not..
+2...still a pain in the butt after 9 years...but with patience...it will go :twisted:

Getting both front foot board slots engaged properly, followed by the two lower rear tabs, then the middle rear upper tab seems to be my sequence of choice...YRMV :roll:

Bill
Yes as a result, last summer I had the dealer do an oil change rather than me adding a little oil.. stupid pn my part.. cost $80.. never again.. Just have to learn to deal with it..
 
1 - 10 of 10 Posts
Top