Suzuki Burgman USA Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My Burgman 200 came down on the left side due to some mud on my lawn. I was able to get it back up and start it up. I reached two places in my errands. When I was leaving the third, I had difficulty starting my scooter. I took the battery out and charged it. That did not help. In going over the owner's manual, I read to check the kill switch and the side stand. The stand was up and the switch was in the right position. In re-starting, the "Chec" word showed on my display. Any pointers in what I can check over next? I've had main fuse trouble with another scooter, but I know that if it was the main fuse, it wouldn't start at all. Any help is appreciated!
 

·
Administrator
Joined
·
17,656 Posts
If the side stand on the 200 is wired the same as a 650 then I'd bet that's the problem.
When the side stand is down it opens the contact. When its up in the riding position the contacts are closed. So I'm guessing that your side stand switch is not working, the bracket is bent or the wires are broken in the fall over.
 

·
Registered
Joined
·
2,261 Posts
That sounds correct from what I know of my 200.
Haven't dropped it* but it seems exactly like an issue with the sidestand switch or wiring.


*yet. Knock on Tupperware...
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Appreciate the replies. Tried re-starting earlier and am convinced it's something in the wiring. Time to take it to the dealer! Thanks again!
 
1 - 4 of 4 Posts
Top