Suzuki Burgman USA Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
My 03 650 currently reads speed in miles per hour. I want it to read in kilometers per hour. How do I go about making this adjustment?

Am I also able to change the odomoter so that distance travelled is also displayed in kilometers instead of miles?
 

·
Registered
Joined
·
153 Posts
Ignition on press and hold the select button and it will change to kilometers. That's what the owners manual says for a 2012 same for the 04 I had so I assume an 03 would be the same.
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #3 ·
Ignition on press and hold the select button and it will change to kilometers. That's what the owners manual says for a 2012 same for the 04 I had so I assume an 03 would be the same.
Thanks Mr Wick. I just tried that but no success. I tried press/hold when in the basic ODO mode and also in both trip-meter modes but none made any change to MPH. I also tried it with pressing and holding Select and Reset together but that only resulted in me being able to change the service interval

I wonder if the early models have a different process?
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #4 ·
Thanks to Randy Russell on the Burgman International Facebook page. He provided the following instructions which worked perfectly. Thanks Randy

1. Turn on ignition switch.
2. Push and hold the "select" button until ODO shows in the display.
3. Holding the "reset" button for 2 seconds wil "toggle" from one to the other.
 

·
Registered
Joined
·
6 Posts
Thanks to Randy Russell on the Burgman International Facebook page. He provided the following instructions which worked perfectly. Thanks Randy

1. Turn on ignition switch.
2. Push and hold the "select" button until ODO shows in the display.
3. Holding the "reset" button for 2 seconds wil "toggle" from one to the other.
Good morning...Joe from far away Malta. I somehow changed my readings from KMH to MPH and I cannot change it back. In your reply you mention a 'reset' button but where do I find that? Mine only has 'select' and 'adjust'...model is a 2010
 

·
Registered
Joined
·
6 Posts
hey there...thanks a lot buddy. It actually isn't cos my bike is a different model. In the meantime however I have resolved my dilemma. As someone here explained, with ignition on you press 'select' until the ODO is selected and then press 'adjust' for 2 seconds...and the readings change from MPH to KPH and vice-versa.
I thank you once again for taking the time to address my problem. All the best and safe riding :)
 
1 - 10 of 10 Posts
Top