Suzuki Burgman USA Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2,832 Posts
Discussion Starter #1
Capacitors Failed! on my 22' Hannspree Monitor , Not sure if you all having this problems with your Monitor but Avoid the Repair Shops, And Be like Bob Vila ,Fix it your Self ,I purchased this Unit in Aug 2008, Just a month ago it started Taking 5-6 Minutes on Booting ON/ I opened it and found 4 1000uf 16v Capacitors 2 of them were Leaking from the Bottom, for more you can go on You tube, All 4 of them had Dome Tops on them.

Don't take it to the Shop there will just try to get more Money out of you and will Call China and order the entire Mother Board, Which is not needed, You just need a Soldering Iron + Solder + Nail Clippers to cut the ends.

Most Symptoms for Bad Capacitors: Black Screen,TV will not stay on,Taking 4-6 Minutes to turn ON/,Lines or bad Picture,ETC,ETC

I would like to here from any one who Did a Capacitor Repair on there LCD,LED ,Plasma TV or Computer Monitor.

Thanks,

Elliott,
 

·
Registered
Joined
·
2,787 Posts
Failed capacitors are one of the first things to check for in any dead electronic device; an ESR (Equivalent Series Resistance) meter will let you find those that are bad but not bulging or leaking.

The Atlas ESR70 is a particularly handy tester...
 

·
Premium Member
Joined
·
12,585 Posts
yep, most common failure for capacitors is "asgo" all the smoke got out and they usually get kinda pregnant looking when that happens, soldering them back in can be a challenge not melting connections on circuit board
 

·
Registered
Joined
·
2,832 Posts
Discussion Starter #4
yep, most common failure for capacitors is "asgo" all the smoke got out and they usually get kinda pregnant looking when that happens, soldering them back in can be a challenge not melting connections on circuit board
from what i read if you put 3 out of 6 for an Example: 35v and replace 3 with a 40 Volt, you can take 3.Seconds off your BOOT Time when you turn TV on!,,with the new Capacitors i installed which are 1000Uf 16v -I took off 2. Seconds normal Boot up time was 4.5 Seconds now it's 3.2 Seconds way Faster then the 4.5 Second Boot Up on ON/

But all is well Since the Install!! had no problems with it Since, There are 2 Caps left inside i might as well Replace them to and maybe take off 0.5 Seconds more off BOOT Up time ON/;)

elliott,
 

·
Registered
Joined
·
3,933 Posts
If it wasn't for Caps and Diodes failing my service calls would have been next to zero.....Back when I was a traveling engineer. Thankfully they did fail often enough for me to travel the world with my solder iron.
I have melted lead on 6 continents.... :)
 
1 - 5 of 5 Posts
Top