Suzuki Burgman USA Forum banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
409 Posts
Discussion Starter #1
I was having issues with center door not latching when I closed the door

I could see the latch inside the holder but would not come out

I removed the two screws at the back of the door but the latch assembly would not come out

By the looks of it, after you remove the 2 screws it should slid down and out from the front

I ended up giving the latch area a quick spray with tri-flow and that did the trick

(in the future how does the latch assembly slid out of the center door cover)

Thanks
 

·
Registered
Joined
·
573 Posts
I've had the same problem a couple of times. I just squirted some WD-40 in it, solved the problem. I've not taken mine out, so can't answer the part about it sliding out.
 

·
Registered
Joined
·
2,810 Posts
I was having issues with center door not latching when I closed the door

I could see the latch inside the holder but would not come out

I removed the two screws at the back of the door but the latch assembly would not come out

By the looks of it, after you remove the 2 screws it should slid down and out from the front

I ended up giving the latch area a quick spray with tri-flow and that did the trick

(in the future how does the latch assembly slid out of the center door cover)

Thanks
If I remember correctly you pull out and up and it comes right out .

TheReaper!
 

·
Registered
Joined
·
1,034 Posts
I did that on my 400 a while ago. It came right out. The 650 is having the same problem but it gets stuck somehow. Idk how though. All I did to fix the 400 one was pretty much rebuild it. Take it apart, then put it back together. Works perfect now. I'll see if some lubricant spray does the trick.
 
1 - 4 of 4 Posts
Top