Suzuki Burgman USA Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
I've had my 400 for just over a week now and have put almost 400 miles on it. Had a great East Tennessee ride yesterday around the Cades Cove loop road in the Great Smoky Mtns Nat'l Park.

Anyway, at about 275 miles I noticed the brakes squeaking some, not all the time, but it seems to be getting a little bit worse. I've noticed quite a bit of brake dust on the wheels as well. Is this normal?

Also, anybody have a good suggestion on cleaning materials. What do y'all use to clean your wheels?
 

·
Premium Member
Joined
·
3,008 Posts
I just wash them with water then wrap them with a rag. I have 2,300 on my 04. Every time I ride it any distance, the rear wheel gets covered in the brake dust. No brake noise on mine.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
Appreciate it

Thanks for the info Roy. I'll be coming up on my first service soon. I think I'll have them look at the brakes while it's there.

By the way, are you in Jonesboro? Isn't that around Kingsport? I'm from South Knoxville.
 

·
Registered
Joined
·
466 Posts
On the AN400 the clutch has a cooling fan and it blows all the clutch dust and belt rubber onto the rear wheel. I used some silicone detailer on the wheel (Don't get it anywhere near the tire) and the dust rinses off with a hose. It sure isn't as tidy as I would like it but it is easy to clean off and it's still WAY better than cleaning chain oil off the rear wheel.
Thanx
Russ
 
1 - 5 of 5 Posts
Top