Suzuki Burgman USA Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello dears! After 50.000km finally I have replaced the belt for my B400 K6 .....but...... before i changed the belt,when i reach the speed of 120-130km/h the rpm max reach the 7rpm 7.5 now with the new belt,when i reach 110 km/h the rpm is 8 ....120km/h rpm is 8.5 sometimes 9.... what did i do wrong...what did i miss?? I installed a Mitsuboshi 947 x 24.4 x 28 x 14,8 brand new belt and all the rollers for original suzuki ones.
 

·
Premium Member
Joined
·
14,260 Posts
With a new OEM belt you should not be turning more than about 6500 rpm at 110 km/h and likely a little less. Not sure what you might have done. Maybe it has to do with the belt you installed. I've only installed an OEM belt on mine and do not know how the belt you installed compares. Possibly it's specs are not exactly the same.
 

·
Registered
Joined
·
3,933 Posts
I just change mine out at 22,000 miles and got the opposite result.
I used all Suzuki parts rollers, belt, and Tranny air filter. I went from 60mph @6000 rpms to 60mph @ 5200 rpms.
I would check the rollers to see if one is in a bind or the variator for full range of movement. Good luck!
 

·
Registered
Joined
·
1,479 Posts
What is the correct size belt for the 400{pre07}?

I can tell you from experience that a larger belt will mess up performance! It will slow down the acceleration and lower the top speed. I tried an aftermarket on my Zuma years ago and that was the result - I used OEM from that point on.
 

·
Registered
Joined
·
3,933 Posts
Maybe it has to do with the belt you installed. I've only installed an OEM belt on mine and do not know how the belt you installed compares. Possibly it's specs are not exactly the same.
Craig, the Mitsubishi belt IS the OEM Belt that Suzuki uses now!
 

·
Registered
Joined
·
3,396 Posts
Yup, likely a different belt
 

·
Premium Member
Joined
·
14,260 Posts
Craig, the Mitsubishi belt IS the OEM Belt that Suzuki uses now!
That may be possible, I don't know. The one I got from Suzuki did not have a manufacture marked on it. Just the Suzuki part number.
 

·
Registered
Joined
·
709 Posts
I just change mine out at 22,000 miles and got the opposite result.
I used all Suzuki parts rollers, belt, and Tranny air filter. I went from 60mph @6000 rpms to 60mph @ 5200 rpms.
I would check the rollers to see if one is in a bind or the variator for full range of movement. Good luck!
Could you tell us more please!! What rollers? OEM is 60mph at 6000 rpm
Where can these parts be purchased? How much? Can she run 90mph now without lugging? Will she do a 100mph now?
 
1 - 11 of 11 Posts
Top