Suzuki Burgman USA Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
So 2015 burgy 650 4550 miles pulled out of driveway and it began. No drive ability problems. Using about 3/4 tank 75 mile round trip @ 85-90 MPH on Speedo.
 

·
Premium Member
Joined
·
8,329 Posts
just one flash or multiple? any corresponding things , like on throttle increase? or decrease?, up hill? (curb) or down hill,? rpm?, lean,? inverted,? barrell roll? Make sure you have the seat release thing done in case you get it to stick and need the seat open without turning her off.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
Flashing the whole time the motor is running. I cannot get the seat to latch at all. Would that throw a code?
 

·
Premium Member
Joined
·
3,443 Posts
No on the seat latch.....I’ve disabled mine and no troubles for this lazy man.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
Thanks Daris! Ya really don’t need to lock anything up under seat I don’t believe a helmet will be stolen.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
Well I Guess I have to take in somewhere. I’m fine doing tires,oil changes ect. But diagnostics and electrical very gray area for me. Anybody know a reputable shop in surprise Arizona area? I called ridenow dealership left message and no return call.
 

·
Premium Member
Joined
·
3,443 Posts
A lot of shops are closed on Mondays . Check your plug wires .
 

·
Registered
Joined
·
16 Posts
Well I Guess I have to take in somewhere. I’m fine doing tires,oil changes ect. But diagnostics and electrical very gray area for me. Anybody know a reputable shop in surprise Arizona area? I called ridenow dealership left message and no return call.
I don't know anybody in Surprise, but D&D in Tempe is a great shop. They are closed on Monday's.
 
1 - 8 of 8 Posts
Top