Suzuki Burgman USA Forum banner

1 - 9 of 9 Posts

·
Premium Member
Joined
·
14,252 Posts
Discussion Starter #1
I just knew it, the minute I decided to take the plunge and buy a scoot something in the house would break. :( Noticed the air was running but the house was getting warmer, checked and the compressor is not comming on. Breakers are not out and getting juice to the unit but nothing happening. Called the repair service and they said they could have someone out this morning :lol: . Hope I don't have to buy a new compressor.
 

·
Registered
Joined
·
1,385 Posts
Hope it is an easy fix, like low on freon or a loose wire.
Would stink if it's the whole unit.

Good luck!!
 

·
Premium Member
Joined
·
14,252 Posts
Discussion Starter #3
Thanks, I know it's not freon because it was cooling well until it just suddenly stopped. Maybe it's just a relay or switch.
 

·
Premium Member
Joined
·
14,252 Posts
Discussion Starter #4
Repair Guy just left, it was the delay switch that keeps the unit from comming right back on and blowing the compressor when you get a brief power outage. Not to bad, only $66 for the switch and $50 for the service charge.

Now I can shop for that Clearview windshield. After the trip this weekend I decided I need about 1 1/2 or 2 inches more height.
 

·
Registered
Joined
·
3,166 Posts
Good deal. Glad it wasn't too expensive! :) Got a friend who just had to replace his... $4500 for a new trane.
 

·
Registered
Joined
·
350 Posts
Thank goodness it was fairly minor. I'm glad I haven't had any problems with the air conditioning on my Burgie. Now, if I can just figure out where it's seat belt is.
 

·
Premium Member
Joined
·
14,252 Posts
Discussion Starter #7
It's the little strap on the right. :p
 

·
Premium Member
Joined
·
14,252 Posts
Discussion Starter #9
I don't even want to think about what it will cost to fill the propane tank. :(
 
1 - 9 of 9 Posts
Top