Suzuki Burgman USA Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4,083 Posts
Discussion Starter #1
Just got the bike back this afternoon from the repair shop. It's been about four weeks since I hit that nasty block of concrete in the middle of the highway.

Anyway, the mechanic said the air filter was filthy and the spark plug was too, and it was checked only 3,000 miles ago and showed good. Most of my riding since that time has been back and forth to work on the highway.

I'm running a power commander on the bike now (it does ride better) but I'd like to add some type of air/fuel ratio monitor. Does anyone out there have something rigged up or attached? My biggest issue is where to attach the monitor display.
 

·
Registered
Joined
·
4,876 Posts
Did you inspect the filter and plug? 3k seems awfully low for those to get so dirty.

I once had a mechanic swear my belt was about to break after 10k, said there were "micro-tears" on it. Hogwash, I didn't see any. The belt lasted another 10k.
 

·
Registered
Joined
·
1,177 Posts
On the 400 don't know about the 650 lots of crud is chucked up by the rear
wheel and right into the air filter inlet, I made a skirt out of a inner tube to stop it and the filter now lasts 3 or 4 times as long.
 

·
Registered
Joined
·
1,177 Posts
It's very crude as I did it as a experiment intending to make a better job if
it worked, it does work very well but as I am selling the scooter I have not
bothered and you don't notice it unless you start looking under the back of the engine.


 

·
Registered
Joined
·
4,083 Posts
Discussion Starter #7
I did take a look at the plug and considering that the valve check co$t$ he said I needed a filter cleaning (I'm running a K&N) and I saw the plug.

It just frustrates me, especially since it was good 3,000 miles ago. Of course, since the end of April through the end of May (until the wreck) I was now driving it back and forth on the highway (about 33 mile round trip) so with this "less than ideal" air intake, I'm not too surprised. The really funny thing is, when I went on long trips (up to 5,000+ miles) I never had these issues.

Oh well.

I can get a good A/F setup, the only problem is they come with a round dial (unless I want to pay over $200 more) and I don't have a good idea of how to mount it, etc.
 

·
Registered
Joined
·
4,083 Posts
Discussion Starter #8
The one I'm looking at is one that Power Commander has.
 
1 - 8 of 8 Posts
Top