Suzuki Burgman USA Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hello,
Can someone give me ideas as to what may be wrong with my 650? I drove it to Myrtle Beach and battery went dead. A police office gave me a jump from his car and I drove it for 1/2 mile. After cutting it off, it would not start back up. The green illumination on the dashboard works, but the rpm never moves. So, I have some battery power, but it won't start. It sounds like it wants to start and engine does turn over, but it won't start. The horn and lights work too. Do you think it is a fuse or a short in the starter switch?

Any advise would be greatly appreciated!

Thanks
 

·
Registered
Joined
·
5,582 Posts
Danny,

you may want to start by eliminating the obvious stuff, main fuses etc....

I would next check the battery to make sure it is holding enough juice to start the scoot since
you seem to be able to crank it but not complete the start cycle.

Considering that you got it started with a quick jump, I highly suspect the battery, but I could be wrong.

how old is the battery?
 

·
Premium Member
Joined
·
14,226 Posts
I agree with LeDude. Charge the battery up then have the battery load tested and if bad replace it.

If the battery test good then I would suspect you have a problem with the charging system. A quick test is to crank the bike then check the DV voltage at the battery with the engine running. You should be getting between 14 and 15.5 VDC with the engine running at 5,000 rpm. If not then you likely have a problem with either the stator or the regulator/rectifier or both. There are test you can run to find out which. To do them you will need a multimeter and you will need to remove the left rear frame cover to gain access to the plugs. The left rear frame cover is the one the fuel door is mounted in.
 

·
Registered
Joined
·
1,468 Posts
As others have said.Battery, stator or the regulator/rectifier one or all would be my guess also. I would start with the battery check and go on from there. What year is your Burg and have you had it from new?
 
1 - 4 of 4 Posts
Top