Suzuki Burgman USA Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello, my 2007 Suzuki Burgman cranks but it doesn't catch. The kickstand is up as it should and I have button in the start position. When i hit the start button it cranks. Also the throttle does nothing.

I've checked the fuses and they appear okay, but I'm not really sure what else to check from this point. This is my first bike and I am still learning.

Any help is greatly appreciated. Thank you.

Kristina
 

·
Registered
Joined
·
713 Posts
Make sure the battery is fully charged and the plug cap is on nice and tight. Was it running before? Did you do anything prior to this issue? Has it been standing for a long time?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Make sure the battery is fully charged and the plug cap is on nice and tight. Was it running before? Did you do anything prior to this issue? Has it been standing for a long time?
I was using it as a daily driver for work until one morning it just wouldn't start. It has been sitting for a few weeks because I've been trying to figure out what is wrong. I charged the battery with a trickle charger overnight but that did not help. Are you referring to the gas cap when you say plug cap or is it something different?
 

·
Registered
Joined
·
713 Posts
Do you have a volt meter? If so check the voltage on the battery. Also try jumping it with cables from another vehicle's battery. If the battery is not showing at least 12 5v it wont start the bike.
 

·
Administrator
Joined
·
18,201 Posts
Kristina, we have a lot of members in Texas, maybe one will stop by and help if we knew what city you are near.
 

·
Registered
Joined
·
1,128 Posts
Not terribly difficult to remove the plug. Under the seat there are 2 storage compartments behind plastic doors. Check if there is a tool pouch kit in one. It shouod have the plug removal tool.
Not difficult to remove and check. Try before you have to tow
 
1 - 9 of 9 Posts
Top