Suzuki Burgman USA Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I've done a search and didn't see anything. My problem is that it would not start. I found that neither of the brake's would light up the brake light. I checked the side stand and used a jumper wire to bypass the kickstand. Still no brake light's or start. I then moved on to the fuses and found nothing wrong there. Next up was the left brake lever. I couldn't hear the switch clicking and it kind of acted like it stopped working so I used a jumper wire on the left lever and it did turn on the brake light and started. The right side is the same way. If you use a jumper wire across the two wires the brake light comes on and I assume completes the circuit. My questions are these.

Has anyone had these problems before?
What are the odds of both switches going bad at the same time?
Does anyone have the part numbers for both switches?
Can I hurt anything by jumping the switches?

I think the best thing to do is purchase new switches. I don't want anyone hitting me if my brake light isn't working. I'm new to the forum so I apologize if this is an old topic
 

·
Registered
Joined
·
3,933 Posts
This problem has happened to others.
The odds are slim but probable as they both get exposed to the elements equally.
Part# can be found on any parts fiche from an OEM dealer.
If you jump them I believe the light would be constantly on.

I would try to clean them with contact cleaner first though. :wink:
 

·
Premium Member
Joined
·
4,015 Posts

Attachments

1 - 3 of 3 Posts
Top